SCM

Discussion Forums: help

Monitor Forum | Start New Thread Start New Thread

 

RE: vtkobject Error trying to delete object with non zero reference count [ reply ]
By: Florence Gutekunst on 2016-09-06 16:05
[forum:3779]
Hello !

I just solved my problem, here is how :

the .obj thing was a bad idea, I then figured out how to resolve these unresolved external symbols :
- I forgot to put the COMPILE_MYCOMPONENT_API in the header of my new component, adding it removed some errors
- I had left the "Q_OBJECT" declaration that was generated by camitk_wizard, which caused other exceptions (Error 1 error LNK2001: unresolved external symbol "public: static struct QMetaObject const AixplorerComponent::staticMetaObject" (?staticMetaObject@AixplorerComponent@@2UQMetaObject@@B) ), this last error disappeared when I removed this line.

Hopes this will help someone !

Best regards,

Florence Gutekunst

vtkobject Error trying to delete object with non zero reference count [ reply ]
By: Florence Gutekunst on 2016-07-11 15:47
[forum:3696]
Hello !

I am encountering an error that appears in a separate window (not the dialog box where the sumofbeta or interpolation errors appear). It's called "vtkOutputWindow", the Message is "Generic Warning: In D:\veprek\vtk\Common\vtkObjectBase.cxx, line 76 Trying to delete object with non-zero reference count.". This triggers an unhandled exception and I am forced to "break".

The error appears when I close normally camitk imp debug, even if I have not launched any action nor even opened any file. I even commented the registrations of my actions in the actionextension file and the problem persists.

I am trying to create some actions to get data from a remote echograph (thus actions not depending from components) and I inspired these actions from the AboutAction and the GridTopology actions. I had to include a remote library (I had the sources) and there were some problems while building (unresolved external symbol errors, which I solved by adding the required .obj files in the additional dependencies). I also created a specific extension, for the echograph has a specific file output.

Any ideas where this error comes from?

Best regards
Florence Gutekunst

   
Powered By FusionForge